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1. Elementos de Minitab para Windows

Al ejecutar Minitab 15 aparece la pantalla de la Figura 1.

Figura 1: Pantalla inicial de Minitab 15

Como en cualquier otra aplicación Windows, esta pantalla inicial puede modificarse en cuanto
al tamaño y a la disposición de sus elementos. Se trata de una ventana tı́pica de una aplicación
Windows que, de arriba a abajo, consta de los siguientes elementos:

En la primera lı́nea aparece la barra de tı́tulo con el nombre de la ventana y los botones de
minimizar, maximizar y cerrar.

En la segunda lı́nea está la barra de menús con los 10 menús que luego comentaremos.



Dra. Josefa Marı́n Fernández. Grado en Información y Documentación. Estadı́stica. Práctica 1 2

Las lı́neas tercera y cuarta conforman la barra de herramientas donde, mediante botones con
iconos, se representan algunas de las operaciones más habituales. Si pasamos el puntero del
ratón por cualquiera de ellos, aparecerá en la pantalla un texto indicando la función que se
activa.

Después aparece la ventana de sesión (Session). Es la parte donde aparecen los resultados de los
análisis realizados. También sirve para escribir instrucciones, como forma alternativa al uso
de los menús.

A continuación tenemos la hoja de datos (Worksheet). Tiene el aspecto de una hoja de cálculo,
con filas y columnas. Las columnas se denominan C1, C2, . . ., tal como está escrito, pero
también se les puede dar un nombre, escribiéndolo debajo de C1, C2, . . . Cada columna es
una variable y cada fila corresponde a una observación o caso.

En la parte inferior aparece (minimizada) la ventana de proyecto (Proyect Manager). En Minitab
un proyecto incluye la hoja de datos, el contenido de la ventana de sesión, los gráficos que se
hayan realizado, los valores de las constantes y de las matrices que se hayan creado, etc.

Para activar la ventana de sesión (Session) podemos hacer clic sobre ella o podemos hacer clic
sobre su icono en la barra de herramientas (primer icono de la Figura 2). Para activar la hoja de
datos (Worksheet) podemos hacer clic sobre ella o podemos hacer clic sobre su icono en la barra de
herramientas (segundo icono de la Figura 2). Para activar la ventana de proyecto (Proyect Manager)
podemos maximizarla o podemos hacer clic sobre su icono en la barra de herramientas (tercer icono
de la Figura 2).

Figura 2: Iconos para activar las ventanas de sesión, de datos o de proyecto

2. Barra de menús

A continuación se da un resumen de lo que se puede encontrar en la barra de menús:

File: Mediante este menú se pueden abrir, crear o grabar los diferentes archivos que Minitab em-
plea, ya sean de datos, instrucciones, resultados o procesos. Igualmente, es posible controlar
las tareas de impresión.

Edit: Permite realizar las tareas habituales de edición: modificar, borrar, copiar, pegar, seleccionar,
etc.

Data: Este menú permite, entre otras cosas, efectuar modificaciones en los archivos de datos: ex-
traer un subconjunto de datos, apilar y desapilar, ordenar, codificar, etc.

Calc: Aquı́ se encuentran todas las opciones relativas a la modificación y generación de nuevas
variables, cálculo de los estadı́sticos, introducción de datos por patrón, cálculo de las distri-
buciones de probabilidad, etc.

Stat: Mediante este menú se accede a los diferentes análisis estadı́sticos que se pueden realizar con
los datos.
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Graph: Permite la creación y edición de diversos tipos de gráficos. Algunos de ellos son también
accesibles a través de determinadas técnicas estadı́sticas.

Editor: Tiene distintas opciones según esté activada la ventana de sesión o la hoja de datos. Con
la ventana de sesión activada permite, por ejemplo, que se pueda escribir en dicha ventana en
lenguaje de comandos.

Tools: Entre otras cosas, permite personificar la barra de herramientas y la barra de menús.

Windows: Dispone de las funciones habituales para controlar las ventanas.

Help: Proporciona ayuda al usuario en el formato tı́pico de Windows.

Para salir del programa se selecciona la opción File ⇒Exit o se pulsa el botón de la esquina superior
derecha: × .

3. Entrada de datos

Antes de realizar ningún análisis estadı́stico es necesario tener un conjunto de datos en uso, para
lo cual podemos proceder de cuatro formas:

Escribirlos a través del teclado.

Obtenerlos desde un archivo.

Pegarlos.

Generarlos por patrón o de forma aleatoria.

Para introducir datos a través del teclado, activamos, en primer lugar, la ventana de datos. En
la parte superior aparece C1, C2, C3, . . . y debajo un espacio en blanco para poner el nombre de
cada variable. La flechita del extremo superior izquierdo de la hoja de datos señala hacia dónde se
mueve el cursor al pulsar la tecla

�� ��Intro . Por defecto apunta hacia abajo,
�� ��↓ ; si se hace clic sobre

ella, apuntará hacia la derecha, �� ��→ . Para escribir datos por columna no hay más que situarse en la
casilla del caso 1, teclear el dato y pulsar la tecla

�� ��Intro . La casilla activa se moverá hacia abajo.
Si tecleamos datos que no son numéricos podemos observar que junto a CJ aparece un guión y la
letra T (es decir, CJ −T ), lo que significa que Minitab reconoce que la variable es cualitativa (o de
texto).

Por ejemplo, podemos introducir los datos de la Figura 3, correspondientes a las calificaciones
de una muestra de 8 alumnos en un determinado examen y el tiempo empleado en realizar dicho
examen.

Si el nombre de la variable (columna) no es suficientemente explicativo, podemos escribir una
descripción de la variable para poder consultarla en cualquier momento. Para ello, hacemos clic
sobre el nombre de la variable (o sobre su número de columna: CJ); pulsamos con el botón derecho
del ratón y seleccionamos Column⇒Description.

Para cambiar el formato de una variable (columna) numérica, hacemos clic sobre el nombre
de la variable (o sobre su número de columna: CJ); pulsamos con el botón derecho del ratón y
seleccionamos Format Column⇒Numeric. Esta opción es importante, por ejemplo, para cambiar el
número de decimales que se muestran en la hoja de datos.

Una hoja de datos puede contener hasta 4 000 columnas, 1 000 constantes y hasta 10 000 000 de
filas, dependiendo de la memoria que tenga el ordenador.
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Figura 3: Ejemplo para introducir datos a través del teclado

4. Grabación de datos

Una vez introducidos los datos, éstos pueden guardarse en un archivo para poder ser utilizados
en cualquier otro momento.

Para guardar únicamente la ventana de datos hay que seleccionar File⇒Save Current Worksheet
ó File⇒Save Current Worksheet As. Por ejemplo, podemos guardar los datos de la Figura 3 en un
archivo que denominaremos Notas Tiempo.mtw.

Si queremos guardar toda la información actual del programa (la hoja de datos, el contenido
de la ventana de sesión, los gráficos que se hayan realizado, los valores de las constantes y de las
matrices que se hayan creado, etc.) usaremos la opción File⇒Save Project ó File⇒Save Project As. Es
muy importante diferenciar entre archivos de datos (.mtw) y archivos de proyectos (.mpj).

También se puede guardar solamente la ventana de sesión. Para ello, la activamos y selecciona-
mos la opción File⇒Save Session Windows As.

5. Lectura de datos

Un archivo sólo puede ser recuperado de la forma en que fue grabado. Si se ha grabado como
hoja de datos (.mtw) se recupera con la opción File⇒Open Worksheet. Si se ha grabado como proyecto
de Minitab (.mpj) se recupera con la opción File⇒Open Proyect.

Normalmente los archivos de datos de Minitab 15 se encuentran en C:\Archivos de programa\Minitab
15\English\Sample Data y, como ya sabemos, llevan la extensión .mtw.

Por ejemplo, podemos abrir el archivo de datos Pulse.mtw. Su contenido fue recogido en una clase
de 92 alumnos. De cada estudiante se observó su pulso antes de correr, Pulse1; su pulso después de
correr, Pulse2; si corrió o no, Ran (1=Sı́ corrió, 2=No corrió); si es fumador o no, Smokes (1=Sı́ fuma,
2=No fuma); el sexo, Sex (1=Hombre, 2=Mujer); su altura en pulgadas, Height; su peso en libras,
Weight; y su nivel de actividad fı́sica, Activity (0=Ninguna actividad fı́sica, 1=Baja, 2=Media, 3=Alta).
Se puede encontrar más información de este archivo de datos con la opción Help⇒Help⇒Indice. Bajo
la frase Escriba la palabra clave a buscar se teclea Pulse.mtw y después se hace clic en Mostrar o se hace
doble clic sobre el nombre de dicho archivo.

Con la opción File⇒Open Worksheet se pueden leer otros tipos de archivos de datos, como hojas
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() Paréntesis
∗∗ Exponenciación
∗ Multiplicación
/ División
+ Suma
− Resta
(a) Operadores aritméticos

< Menor que
> Mayor que
<= Menor o igual que
>= Mayor o igual que
= Igual que
<> No igual que
(b) Operadores relacionales

AND Operador Y
OR Operador O
NOT Operador NO
(c) Operadores lógicos

Tabla 1: Operaciones aritméticas, relacionales y lógicas

de cálculo de Excel, Lotus 1-2-3, dBase, etc. Para tener información más detallada sobre el tipo de
archivos que se pueden leer, se puede seleccionar File⇒Open Worksheet y, en el cuadro de diálogo
resultante, se hace clic sobre Ayuda.

6. Opciones principales del menú Calc

Si queremos que en la ventana de sesión (Session) aparezcan los comandos que va a utilizar
Minitab en las opciones que vamos a explicar en los siguientes apartados, activamos la ventana de
sesión y luego seleccionamos Editor⇒Enable Commands.

6.1. Operaciones por filas mediante la opción Calc⇒Calculator

En este apartado vamos a ver el modo de generar nuevas variables mediante transformaciones
efectuadas sobre los valores de las variables ya definidas.

Para practicar esta opción tendremos abierto el archivo de datos Pulse.mtw.

En la Tabla 1 se encuentran recogidos los operadores aritméticos, relacionales y lógicos que
están permitidos. Tanto las expresiones aritméticas como las lógicas se evalúan de izquierda a dere-
cha. Todas las expresiones entre paréntesis se evalúan antes que las que están fuera de los paréntesis
y ante varios operadores en el mismo nivel, el orden de preferencia (de mayor a menor) es el que
figura en la Tabla 1 (de arriba hacia abajo).

Para construir una nueva variable mediante transformaciones de otras ya existentes, se tiene que
elegir la opción Calc ⇒Calculator, con lo que se abre una ventana que tiene cinco partes fundamen-
tales: arriba a la derecha está el lugar para escribir el nombre de la nueva variable (Store result in
variable), a la izquierda aparece la lista de variables y constantes existentes, a la derecha está el lugar
destinado a la definición de la nueva variable (Expression), debajo hay una calculadora y la lista de
funciones que se pueden utilizar (Functions).

En primer lugar se asigna un nombre a la variable que queremos generar, escribiendo el mismo
en el cuadro Store result in variable. Normalmente se va a tratar de una variable nueva, pero también
cabe la posibilidad de especificar una de las ya existentes. En tal caso la modificación consistirá en
sustituir los valores antiguos de la variable con los nuevos resultantes de la transformación numérica
que se efectúe.

Una vez que se ha asignado el nombre a la variable, el siguiente paso es definir la expresión
que va a permitir calcular los valores de la misma. Tal expresión se escribe en el cuadro Expression
y puede constar de los siguientes elementos: nombres de variables del archivo original, constan-
tes, operadores y funciones. Para escribir dicha expresión, se puede teclear directamente pero es
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recomendable emplear la calculadora, la lista de variables y constantes y la lista de funcio-
nes (haciendo clic dentro del recuadro Expression y haciendo doble clic sobre la variable, sobre la
constante o sobre la función). Una vez que hemos terminado de escribir la expresión, pulsamos en
OK.

Por ejemplo, del archivo de datos Pulse.mtw vamos a calcular la media geométrica de las varia-
bles Pulse1 y Pulse2 (raı́z cuadrada del producto de ambas variables; es decir, producto de ambas
variables elevado a 1/2). Para ello, seleccionamos la opción Calc⇒Calculator; en Store result in variable
tenemos que teclear la posición de la columna que contendrá los resultados (una columna, CJ, que
esté vacı́a) o el nombre que queremos darle a dicha columna. Si el nombre contiene espacios en
blanco, guiones, paréntesis, etc., hay que escribirlo entre comillas simples; por ejemplo, vamos
a denominar a la nueva variable ‘Media geométrica Pulse1 Pulse2’. En Expression tenemos que colocar
(utilizando, como hemos dicho, la calculadora y la lista de variables) la operación que se realiza
para determinar la media geométrica indicada: (‘Pulse1’ * ‘Pulse2’)**(1 / 2). Por último,
pulsamos en OK.

6.2. Operaciones por columnas mediante la opción Calc⇒Column Statistics

La opción Calc⇒Column Statistics calcula, para una columna (variable), uno de los estadı́sticos
siguientes:

Sum suma
n∑

i=1

xi

Mean media aritmética x =

n∑
i=1

xi

n

Standard deviation cuasi-desviación tı́pica S =

√√√√√
n∑

i=1

(xi − x)2

n− 1

Minimum mı́nimo dato xmin

Maximum máximo dato xmax

Range recorrido total R = xmax − xmin

Median mediana=valor que deja por debajo de él el 50 % de los datos

Sum of squares suma de cuadrados
n∑

i=1

x2
i

N total número total de casos=N nonmissing+N missing

N nonmissing número de casos para los cuales sabemos el resultado de la variable = n

N missing número de casos para los cuales no sabemos el resultado de la variable

El resultado del estadı́stico calculado se puede almacenar (opcionalmente) en una constante, si
lo indicamos en Store result in.
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Por ejemplo, del archivo de datos Pulse.mtw vamos a determinar la cuasi-desviación tı́pica de
los datos de la columna Height y vamos a guardar el resultado en una constante que vamos a deno-
minar cuasi-desv-Altura. Para ello, seleccionamos Calc⇒Column Statistics; activamos la opción Stan-
dard deviation; hacemos clic en el recuadro que hay a la derecha de Input variable y seleccionamos
(haciendo doble clic sobre su nombre) la columna Height; en Store result in tecleamos ‘cuasi-desv-
Altura’ (con comillas simples, al principio y al final, por llevar guiones) y pulsamos en OK. Mini-
tab guarda esta constante también como K1 (o, en general, KJ , con J = 1, 2, 3, . . .). Esta cons-
tante se puede consultar, en cualquier momento, en la ventana Proyect Manager (concretamente, en
Worksheets\Pulse.mtw\Constants) y puede ser utilizada en cálculos posteriores.

�� ��Importante No es posible cambiar el número de decimales de los resultados que aparecen en la ventana
de sesión. Hay una forma de aumentar el número de decimales de un resultado
solamente en el caso en que sea posible almacenar dicho resultado en una constante; es
decir, si en el cuadro de diálogo en el cual estamos solicitando a Minitab que calcule dicho
resultado aparece la opción de guardar el resultado. Si, por ejemplo, tenemos guardado un
resultado en la constante K1 y queremos tener una precisión de 6 decimales, hacemos lo
siguiente: seleccionamos Data⇒Copy⇒Constants to Column; hacemos clic en el recuadro que
hay debajo de Copy from constants y seleccionamos (haciendo doble clic sobre su nombre) la
constante K1; en In current worksheet, in column tenemos que teclear la posición de la columna
que contendrá el resultado (una columna, CJ, que esté vacı́a) o el nombre que queremos darle a
dicha columna. Recordemos que si el nombre contiene espacios en blanco, guiones, paréntesis,
etc., hay que escribirlo entre comillas simples. Si hemos puesto un nombre a esta columna,
desactivamos Name the column containing the copied data. Por último, pulsamos en OK. Una
vez que tenemos la constante K1 copiada en una columna, podemos cambiar su formato
como hemos visto anteriormente: hacemos clic sobre el nombre de la variable (o sobre su
número de columna: CJ ); pulsamos con el botón derecho del ratón; seleccionamos Format
Column⇒Numeric; activamos Fixed decimal; en Decimal places tecleamos 6 y pulsamos en
OK.

Para practicar lo anterior, vamos a obtener una precisión de 7 decimales en el resultado de la
cuasi-desviación tı́pica de la variable Height (Altura) de la hoja de datos Pulse.mtw.

6.3. Operaciones por filas mediante la opción Calc⇒Row Statistics

La opción Calc⇒Row Statistics calcula los mismos estadı́sticos del apartado anterior, pero por
filas, en vez de por columnas. En este caso, a diferencia del anterior, es totalmente necesario rellenar
el recuadro Store result in ya que los resultados forman una nueva variable o columna.

Por ejemplo, del archivo de datos Pulse.mtw vamos a hallar la media aritmética (por filas) de la
variables Pulse1 y Pulse2 y guardar los resultados en una nueva columna (variable) que denominare-
mos Media aritmética Pulse1 Pulse2. Para ello, seleccionamos Calc⇒Row Statistics; activamos la opción
Mean; hacemos clic en el recuadro que hay debajo de Input variables y seleccionamos (haciendo doble
clic sobre sus nombres) las columnas Pulse1 y Pulse2; en Store result in tecleamos ‘Media aritmética
Pulse1 Pulse2’ (con comillas simples, al principio y al final, por tener espacios en blanco) y pulsamos
en OK.

Las operaciones realizadas con esta opción también pueden realizarse mediante Calc⇒Calculator.
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6.4. Tipificación de datos

Esta opción se entenderá mejor cuando estudiemos la tipificación de una variable aleatoria Nor-
mal (Tema 6).

Con la opción Calc⇒Standardize se calcula, en una nueva columna (variable), los datos tipificados
o estandarizados de una de las columnas de nuestra hoja de datos. Hay varias formas de tipificar los
datos pero la más usual es la siguiente: Si xi son los datos de la muestra, x es la media (aritmética)
y s es la desviación tı́pica, los datos tipificados o estandarizados son zi = (xi − x)/s. Esto se logra
dejando activada la opción subtract mean and divide by standard deviation.

Por ejemplo, vamos a crear una nueva variable (columna), que denominaremos Pulse1 Tipificada,
que contendrá los datos de Pulse1 tipificados. Para ello, seleccionamos Calc⇒Standardize; en Input
columns seleccionamos (haciendo doble clic sobre su nombre) la columna Pulse1; en Store results
in tecleamos ‘Pulse1 Tipificada’ (con comillas simples, al principio y al final, por tener espacios en
blanco); dejamos activada la opción Substract mean and divide by standard deviation y pulsamos en OK.

Las operaciones realizadas con esta opción también pueden realizarse mediante Calc⇒Calculator.

6.5. Creación de datos por patrón

Con la opción Calc⇒Make Patterned Data se generan datos siguiendo un determinado patrón.

Por ejemplo, si queremos generar una lista de los siguientes 100 números: 0′01, 0′02, 0′03, . . .,
1, seguiremos los siguientes pasos:

Como estos datos no tienen nada que ver con los datos del archivo Pulse.mtw, abrimos una nueva
hoja de datos con la opción File⇒New. En el cuadro de diálogo que aparece seleccionamos Minitab
Woorksheet. A esta nueva hoja de datos Minitab le asignará el nombre Worksheet J , siendo J un
número natural. Luego podemos cambiarle el nombre con la opción File⇒Save Current Worksheet
As. Seleccionamos, a continuación, la opción Calc⇒Make Patterned Data⇒Simple Set of Numbers. En
Store patterned data in podemos teclear C1 o un nombre, por ejemplo ‘Patrón entre 0 y 1’ (con comillas
simples, al principio y al final, por tener espacios en blanco). En From first value tecleamos 0,01, en
To last value escribimos 1 y en In steps of ponemos 0,01. Tanto en List each value como en List the whole
sequence dejamos lo que está puesto por defecto, que es 1. Una vez obtenida la nueva columna vamos
a denominar Ejemplo Practica 1.mtw a la nueva hoja de datos utilizando la opción File⇒Save Current
Worksheet As.

6.6. Creación de resultados aleatorios de una distribución conocida

La utilidad principal de esta opción la veremos en la Práctica 3.

En Minitab podemos generar datos de distribuciones usuales utilizando la opción Calc⇒Random
Data.

Por ejemplo, en el archivo de datos Ejemplo Practica 1.mtw vamos a generar 100 datos de una
distribución Uniforme en el intervalo (0, 1) (es decir, 100 números aleatorios comprendidos entre
0 y 1). Para ello, seleccionamos la opción Calc⇒Random Data⇒Uniform; en Number of rows of data to
generate ponemos 100; en Store in column escribimos el nombre de la nueva columna: ‘100 datos de
U(0,1)’ (con comillas simples, al principio y al final, por tener espacios en blanco y paréntesis); en
Lower endpoint tecleamos 0 y en Upper endpoint escribimos 1.
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7. Opciones principales del menú Data

Sólo se explicarán algunas de las opciones más utilizadas del menú Data. En el cuadro de diálogo
de cada opción existe un botón Help que la explica bastante bien.

7.1. Apilamiento de columnas

Con la opción Data⇒Stack⇒Columns se pueden apilar varias columnas en una sola. Opcional-
mente se puede indicar de qué columna procede cada valor mediante una nueva variable (subı́ndi-
ces). Si no se hace esta indicación no se podrá identificar la procedencia de cada dato.

Para practicar esta opción vamos a apilar los datos de la columna Patrón entre 0 y 1 y de la columna
100 datos de U(0,1) del archivo de datos Ejemplo Practica 1.mtw. Para ello, seleccionamos la opción
Data⇒Stack⇒Columns; activamos el recuadro Stack the following columns y seleccionamos (haciendo
doble clic sobre sus nombres) las dos columnas que queremos apilar: ‘Patrón entre 0 y 1’ ‘100 datos de
U(0,1)’; en Store stacked data in activamos la opción Column of current worksheet y tecleamos la posición
de una columna que esté vacı́a, por ejemplo, C3. En Store subscripts in tecleamos la posición de la
columna en la que queremos guardar la procedencia de cada dato, por ejemplo, C4. Es conveniente
dejar activada la opción Use variable names in subscript column.

7.2. Desapilamiento de columnas

La opción Data⇒Unstack columns permite separar una columna en varias según los valores de la
columna de alguna variable (que contiene los subı́ndices). Esta opción es la contraria de la explicada
en el apartado anterior.

Por ejemplo, de la hoja de datos Pulse.mtw vamos a desapilar los resultados de la variable Pulse2
(pulso después de correr) según los resultados de la variable Ran (¿corrió o no?). Para ello, selec-
cionamos Data⇒Unstack Columns; en Unstack the data in seleccionamos (haciendo doble clic sobre su
nombre) la variable o columna Pulse2; en Using subscripts in seleccionamos (haciendo doble clic so-
bre su nombre) la columna que contiene la procedencia de cada dato, que es Ran; en Store unstacked
data in activamos la opción After last column in use y dejamos activado Name the columns containing the
unstaked data.

7.3. Ordenación de los datos

La opción Data⇒Sort ordena los datos de una columna según los resultados de una o varias
columnas. Lo normal es ordenar una columna según los resultados de dicha columna. Esto es lo que
vamos a explicar.

Por ejemplo, en la hoja de datos Pulse.mtw vamos a crear una nueva variable (columna), de-
signada por Pulse1 ordenado, que contenga los resultados de la variable Pulse1 ordenados de menor
a mayor. Para ello, seleccionamos Data⇒Sort; en Sort column seleccionamos (haciendo doble clic
sobre su nombre) la variable Pulse1; en By column volvemos a seleccionar la misma columna. Si de-
jamos desactivada la opción Descending la ordenación se hará de menor a mayor resultado, que es lo
que queremos. En Store sorted data in activamos Column of current worksheet y tecleamos el nombre que
queremos ponerle a dicha columna: ‘Pulse1 ordenado’ (con comillas simples, al principio y al final,
por tener espacios en blanco).
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Tenemos que tener cuidado con la ordenación de columnas debido a que los resultados de esta
nueva variable no guardan correspondencia con los casos originales. Por ejemplo, la primera persona
observada tiene un pulso antes de correr (resultado de Pulse1) igual a 64 pulsaciones por minuto, no
48 pulsaciones por minuto, como nos ha salido en el primer lugar de la columna Pulse1 ordenado.
Como podemos observar, el menor valor de Pulse1 es 48 y el mayor valor es 100.

7.4. Codificación o clasificación de datos

La opción Data⇒Code permite la clasificación o codificación de los datos de una columna. Se
puede codificar transformando datos numéricos en datos numéricos, datos numéricos en datos de
texto, datos de texto en datos de texto, datos de texto en datos numéricos, etc.

Por ejemplo, con la hoja de datos Pulse.mtw podemos codificar la variable Pulse1 de la forma
siguiente:

intervalo de Pulse1 nueva categorı́a
[48,65] Pulso bajo
(65,83] Pulso medio

(83,100] Pulso alto

Para ello, seleccionamos Data⇒Code⇒Numeric to Text. En Code data from columns seleccionamos
(haciendo doble clic sobre su nombre) la variable Pulse1. En Store coded data in column escribimos el
nombre la nueva variable, por ejemplo, ‘Codificación de Pulse1’ (con comillas simples, al principio y al
final, por tener espacios en blanco). En la primera lı́nea de Original values escribimos 48:65 (todos los
resultados comprendidos entre 48, incluido, y 65, incluido) y en la primera lı́nea de New escribimos
Pulso bajo. En la segunda lı́nea de Original values escribimos 65:83 (todos los resultados comprendidos
entre 65, sin incluir, y 83, incluido) y en la segunda lı́nea de New escribimos Pulso medio. En la tercera
lı́nea de Original values escribimos 83:100 (todos los resultados comprendidos entre 83, sin incluir, y
100, incluido) y en la tercera lı́nea de New escribimos Pulso alto.

8. Algo más sobre la ventana Session

Ya hemos visto que una de las utilidades de la ventana de sesión es la de servir para la presen-
tación de los comandos aplicados en cada opción de las que hemos realizado. Además, podemos
repasar resultados obtenidos con anterioridad moviéndonos hacia arriba en dicha ventana. Los re-
sultados incluidos en la ventana de sesión pueden grabarse como un archivo de texto (.txt) activando
dicha ventana y seleccionando File⇒Save Session Window As. También podemos usar las opciones de
marcar, copiar y pegar para pasar los resultados obtenidos a editores de texto. Además, es posible
imprimir todos sus contenidos activando dicha ventana y seleccionando File⇒Print Session Window.

Una vez seleccionada la ventana de sesión, la activación de la opción Editor⇒Enable Commands
permite ejecutar los comandos de Minitab. Por ejemplo, si tecleamos en la ventana de sesión (tras
MTB >) Mean C1 y pulsamos el botón

�� ��Intro , el programa calcula media aritmética de los datos
de la columna C1 de la hoja de datos activa. Si escribimos Let K2=1/3 y pulsamos el botón

�� ��Intro ,
el programa guarda el valor 1/3 en la correspondiente constante. Si tecleamos ahora Print K2, el
programa nos da el valor de dicha constante.

Lógicamente, es más sencillo el manejo de Minitab utilizando los menús, pero los comandos
pueden incorporarse posteriormente a los programas (macros) que construyamos. Además, una vez
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habilitado el lenguaje de comandos, cuando ejecutemos una opción del menú, ésta se escribirá en la
ventana de sesión, con lo que podremos ver cuál es la sintaxis concreta del comando que queremos
utilizar.

Para que el contenido de la ventana de sesión pueda modificarse, debemos activar dicha ven-
tana y seleccionar Editor⇒Output Editable, con lo que podemos rectificar fácilmente cualquier error,
modificar comandos ejecutados anteriormente o simplemente preparar los resultados para ser im-
primidos.

Una vez activada la opción Editor⇒Output Editable, la ventana de sesión es el lugar en el que
se ejecutan los macros o programas, tanto los que construyamos nosotros como los que incluye
Minitab o los realizadas por otros usuarios. Los macros llevan la extensión .mac y normalmente
están incluidos en el directorio C:\Archivos de programa\Minitab 15\English\Macros. En la versión 15
de Minitab solamente se incluyen cuatro macros, pues los resultados del resto de los macros de la
versión anterior pueden conseguirse con distintas opciones de los menús.

9. Algo más sobre la ventana Proyect Manager

Esta ventana presenta toda la información disponible en forma de directorios. Resulta ser es-
pecialmente útil cuando se maneja una gran cantidad de datos. El directorio Session nos muestra,
de forma resumida y organizada, la información correspondiente a dicha ventana. El directorio His-
tory presenta (en lenguaje de comandos) todas las operaciones que hemos realizado. A diferencia
de lo que ocurrı́a con la ventana de sesión, no sirve para ejecutar comandos ni macros, y en él no
se muestran los resultados de la ejecución de los comandos. En este directorio aparece solamente
el programa de las operaciones que hemos realizado, y su contenido puede consultarse o copiarse
directamente para la realización de macros. Los directorios de datos, Worksheets, contienen infor-
mación sobre las columnas (variables), constantes y matrices manejadas en cada ventana de datos
que se esté utilizando. Además, indican el número de datos incluidos en una columna, ası́ como los
datos ausentes de la misma (Missing).

10. Ejercicios propuestos

1.1. En la Tabla 2 se muestra el número anual de usuarios de una biblioteca determinada y el
número anual de préstamos durante 10 años elegidos al azar.

a) Crea un nuevo proyecto de Minitab.

b) Introduce los datos (sin incluir, obviamente, la primera columna, que indica el número
de caso). Pon los siguientes nombres a las dos variables: Usuarios y Préstamos. Graba la
hoja de datos en un archivo denominado Prestamos.mtw

c) Calcula, en una nueva columna, la variable que indica el porcentaje anual de préstamos
por usuario, resultado de multiplicar por 100 el resultado de dividir el número anual
de préstamos entre el número anual de usuarios. Pon a la nueva variable el siguiente
nombre: PPU. Haz que los resultados aparezcan con tres decimales. Pon una etiqueta
descriptiva a esta variable. Vuelve a grabar la hoja de datos.

d) Calcula el mı́nimo y el máximo de la variable PPU.
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año usuarios préstamos

1 296 155
2 459 275
3 602 322
4 798 582
5 915 761
6 1145 856
7 1338 1030
8 1576 1254
9 1780 1465
10 2050 1675

Tabla 2

e) Clasifica los datos de la variable PPU en 4 categorı́as o intervalos de la misma amplitud.
Llama a la nueva variable Intervalos PPU. Las categorı́as han de denotarse como lo hace-
mos en las clases de teorı́a; es decir, [a, b] o (a, b] (sustituyendo, obviamente, a y b por
los lı́mites de los intervalos de clase). Vuelve a grabar la hoja de datos.

f) Graba el proyecto con el siguiente nombre: Ejercicio1-1.mpj

1.2. En la Tabla 3 aparece el número anual de transacciones de referencia y el número anual de
transacciones de referencia finalizadas en 20 biblioteca elegidas al azar.

biblioteca tipo de biblioteca transacciones de referencia transacciones de referencia finalizadas

1 1 11500 9400
2 1 8600 7200
3 1 20400 18100
4 1 5800 4600
5 1 6500 5800
6 1 13700 10900
7 1 12400 11200
8 1 5300 4700
9 1 6700 5600
10 1 15600 12500
11 2 1900 1700
12 2 9600 7800
13 2 8400 6900
14 2 6200 4900
15 2 7700 5900
16 2 5600 4200
17 2 6200 4900
18 2 4800 3500
19 2 3800 2600
20 2 2400 2200

Tabla 3

a) Crea un nuevo proyecto de Minitab.
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b) Introduce los datos (sin incluir, obviamente, la primera columna, que indica el número
de caso). Pon los siguientes nombres a las variables: Tipo, TR y TRF. Pon una etiqueta
descriptiva a cada variable. En lo que respecta a la variable Tipo hay que dejar claro
que el valor 1 significa biblioteca pública y el valor 2 significa biblioteca universitaria.
Graba la hoja de datos en un archivo denominado Transacciones.mtw

c) Crea una nueva variable, denominada Tipo biblioteca, que contenga las categorı́as de la
variable Tipo designadas de la siguiente manera: bib. pública (en vez de 1) y bib. univer-
sitaria (en vez de 2). Vuelve a grabar la hoja de datos.

d) Calcula, en una nueva columna, la variable que indica el porcentaje de transacciones de
referencia finalizadas, que se determina multiplicando por cien el resultado de dividir
el número anual de transacciones de referencia finalizadas entre el número anual de
transacciones de referencia. Pon a la nueva variable el siguiente nombre: Porcentaje TRF.
Haz que los resultados aparezcan con 5 decimales. Pon una etiqueta descriptiva a esta
variable. Vuelve a grabar la hoja de datos.

e) Desapila los resultados de la variable Porcentaje TRF según los resultados de la variable
Tipo biblioteca. Calcula la media aritmética de estas dos nuevas columnas. Interpreta los
resultados.

f) Ordena los datos de la variable Porcentaje TRF en orden creciente. Pon un nombre ade-
cuado a la nueva columna. Pon una etiqueta descriptiva a esta columna. A partir de esta
ordenación determina el valor mı́nimo y el valor máximo de Porcentaje TRF.

g) Clasifica los datos de la variable Porcentaje TRF en 3 categorı́as o intervalos de la misma
amplitud. Llama a la nueva variable Intervalos Porcentaje TRF. Las categorı́as han de de-
notarse como lo hacemos en las clases de teorı́a; es decir, [a, b] o (a, b] (sustituyendo,
obviamente, a y b por los lı́mites de los intervalos de clase). Vuelve a grabar la hoja de
datos.

h) Graba el proyecto con el siguiente nombre: Ejercicio1-2.mpj


